Dashboard unavailable for some users

Incident Report for Make

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 17:14 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 16:52 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 17, 2026 - 16:51 CEST

Update

We are continuing to investigate this issue.
Posted Apr 17, 2026 - 16:36 CEST

Investigating

We are currently experiencing problems with loading the dashboard for some users. The root cause is identified and we are currently working on a fix.
Posted Apr 17, 2026 - 16:35 CEST
This incident affected: Website (eu1.make.com, eu2.make.com, us1.make.com, us2.make.com, eu1.make.celonis.com, us1.make.celonis.com).