Datastores not appearing in make UI

Incident Report for Make

Resolved

The issue causing Datastore content to disappear from the UI has been fixed.
All Datastore contents are now visible across public and enterprise zones, and all platform features are fully operational.
Posted Mar 25, 2026 - 09:48 CET

Monitoring

A fix has been implemented, content of the datastores is now being displayed in the Make UI.
Posted Mar 25, 2026 - 09:28 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2026 - 09:02 CET

Update

Scenarios using datastore modules are unaffected.
Posted Mar 25, 2026 - 08:22 CET

Investigating

We are currently investigating an issue where Datastores are not appearing within the Make UI across all public and enterprise zones.
Please note that scenario executions remain unaffected and are running as expected.
Posted Mar 25, 2026 - 08:11 CET
This incident affected: Website (eu1.make.com, eu2.make.com, us1.make.com, us2.make.com, eu1.make.celonis.com, us1.make.celonis.com).