email notifications on us1.make.com
Incident Report for Make
Resolved
The issue was resolved
Posted Jul 26, 2022 - 12:27 CEST
Investigating
We have detected a problem with sending email notifications, email notifications for some users of us1.make.com might be delayed or missing on. Investigation is in progress.
Posted Jul 26, 2022 - 11:23 CEST
This incident affected: Website (us1.make.com).