Issues with payments and subscriptions

Incident Report for Make

Resolved

This incident has been resolved
Posted Aug 20, 2025 - 13:15 CEST

Monitoring

We have identified the issue and implemented a fix. We will continue monitoring the service before we consider this fully resolved.
Posted Aug 20, 2025 - 12:28 CEST

Investigating

We are observing issues with our payment processing services. There might be potential issues with payments and subscriptions. This issue affects all our zones. Scenario processing is not affected.
Posted Aug 20, 2025 - 11:58 CEST
This incident affected: Website (make.com).