Executions on the us2.make.com not working

Incident Report for Make

Monitoring

We have identified the root cause of the execution issues on the US2 (us2.make.com) zone. The disruption was linked to a service instability with one of our upstream third-party providers.

As we continue to investigate the recent issue on US2 zone, our investigation has identified a specific window of possible data loss. Webhooks reaching Make between 14:36 and 14:51 CET were not processed correctly due to the service disruption.
Posted Mar 10, 2026 - 15:48 CET

Identified

We have identified the root cause of the execution issues on the US2 (us2.make.com) zone. The disruption was linked to a service instability with one of our upstream third-party providers.

While systems are back to normal, please be aware that scenario executions might be delayed as we process the remaining backlog. We are working closely with the third-party provider to ensure a permanent fix and to prevent any recurrence.
Posted Mar 10, 2026 - 15:31 CET

Update

Service recovered. The issues affecting scenario executions on us2.make.com since 14:40 CET have been restored. Scenarios execution recovered. You may experience a delay in the scenario executions.

We are continuing our investigation into the root cause.
Posted Mar 10, 2026 - 15:07 CET

Investigating

We are experiencing problems with scenario executions on the US2 (us2.make.com) zone starting around 14:40 CET. We are currently investigating the issue.
Posted Mar 10, 2026 - 14:56 CET
This incident affects: Scenario Executions (us2.make.com).