Scenario Execution Delays

Incident Report for Make

Resolved

The recent performance degradation impacting scheduled scenarios in our us2 zone has been fully resolved. Our team has deployed a successful remediation, and we have since confirmed that all affected components are stable and operating within expected parameters.
Posted Oct 09, 2025 - 14:05 CEST

Monitoring

The team has identified and fixed the issue and the platform is operating normally again.
Posted Oct 08, 2025 - 16:11 CEST

Investigating

We are currently investigating an issue that is causing delays for scheduled scenario executions in the us2.make.com zone. Our team is actively working on a resolution and will provide updates as they become available.
Posted Oct 08, 2025 - 15:53 CEST
This incident affected: Scenario Executions (us2.make.com).