us1.make.com zone unstable

Incident Report for Make

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 14:33 CEST

Monitoring

us1.make.com zone was unstable today from 10:53 - 11:02 CET. Users might have encountered login issues, webhook delays, and missing email notifications. The issue is no longer present, Make app is accessible and functional. We are currently monitoring the issue.
Posted Jul 23, 2025 - 11:34 CEST
This incident affected: Website (us1.make.com), Responsive Webhooks (us1.make.com), Scenario Executions (us1.make.com), and Apps (us1.make.com).