New users registrations not working

Incident Report for Make

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 20:06 CET

Monitoring

A fix has been implements.
New users registration are working again.
Posted Dec 19, 2025 - 19:39 CET

Identified

Problem has been identified.
Our engineering team is working on the fix.
Posted Dec 19, 2025 - 19:22 CET

Investigating

We are currently experiencing issues with registrations of new users.
Our teams are investigating the cause of the issues.
Service functionality is not being affected.
Posted Dec 19, 2025 - 19:02 CET
This incident affected: Website (eu1.make.com, eu2.make.com, us1.make.com, us2.make.com, make.com).