Executions Delayed in EU1

Incident Report for Make

Resolved

The recent performance degradation impacting scheduled scenarios in our EU(eu1.make.com) has been fully resolved. All affected components are stable and operating as expected.
Posted Oct 27, 2025 - 13:44 CET

Monitoring

The team has identified and fixed the issue. The platform is now operating normally, and all zones are working as expected.
We’ll continue to monitor the situation to ensure ongoing stability.
Posted Oct 27, 2025 - 11:41 CET

Update

We’re continuing to investigate the issue. We’re seeing gradual improvements in scenario performance however, some executions in EU1 (eu1.make.com) may still experience delays.
Our team is working on a permanent resolution and will provide further updates as they become available.
Posted Oct 27, 2025 - 11:21 CET

Investigating

We’re currently investigating an issue causing slow or delayed executions in the EU1 (eu1.make.com) since around 10:00 CET. Our team is working to identify the cause and restore normal performance as soon as possible.
Posted Oct 27, 2025 - 10:32 CET
This incident affected: Website (eu1.make.com), Responsive Webhooks (eu1.make.com), and Scenario Executions (eu1.make.com).