Dashboard unavailable for some users

Incident Report for Make

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 11:16 CEST

Monitoring

Fix deployed. Monitoring.
Posted Apr 20, 2026 - 11:15 CEST

Update

We are currently experiencing problems with loading the dashboard for some users. The root cause is identified and we are currently deploying the a fix.
Posted Apr 20, 2026 - 10:54 CEST

Investigating

We are currently experiencing problems with loading the dashboard for some users. The root cause is identified and we are currently deploying the a fix.
Posted Apr 20, 2026 - 10:52 CEST
This incident affected: Website (eu1.make.com).