Scenarios execution degraded - eu2.make.com

Incident Report for Make

Resolved

This incident has been resolved.
Posted May 13, 2026 - 20:08 CEST

Monitoring

Our team has identified the cause of the zone overload and applied mitigations. eu2.make.com is operational again and we are monitoring the systems
Posted May 13, 2026 - 16:10 CEST

Update

We are continuing to investigate this issue.
Posted May 13, 2026 - 14:15 CEST

Update

Our engineers are continuing to investigate this issue with highest priority. We will provide a further update within the next hour.
Posted May 13, 2026 - 14:15 CEST

Investigating

We are currently investigating an issue in the zone eu2.make.com which can affect scenario executions and credits.

We will provide more updates within the next hour.
Posted May 13, 2026 - 12:49 CEST
This incident affected: Website (eu2.make.com) and Scenario Executions (eu2.make.com).