Google Sheets app returns error 429 - unusual traffic detected

Incident Report for Make

Resolved

Google Sheets error 429 incident was resolved.
Posted Apr 15, 2025 - 15:19 CEST

Monitoring

Google Sheets app and modules are available again. We keep monitoring the situation.
Posted Apr 15, 2025 - 11:43 CEST

Investigating

We are currently experiencing an issue with the Google Sheets app and modules, which are resulting in error 429 - unusual traffic detected. Our team is investigating the issue and working to resolve it as quickly as possible. We will provide updates as soon as more information is available. Thank you for your patience.
Posted Apr 15, 2025 - 11:12 CEST
This incident affected: Apps (eu1.make.com, eu2.make.com, us1.make.com, eu1.make.celonis.com, us1.make.celonis.com, make.com, us2.make.com).