Problems displaying history logs in EU1

Incident Report for Make

Monitoring

We identified the problem that prevented logs from being loaded.

We solved the issue by and will actively monitor this for the next days. No data was affected and you can now see the log details again.
Posted Feb 27, 2026 - 22:00 CET

Update

We continue to investigate the issue. We can see the data does exist and the problem is limited to displaying it for all cases we could find.
Posted Feb 27, 2026 - 21:18 CET

Investigating

We are investigating issues with loading module history logs in EU1 (eu1.make.com)
It's possible to open history logs, but trying to open a module detail results in infinite loading in some cases.
Scenario executions are not impacted.
Posted Feb 27, 2026 - 20:48 CET
This incident affects: Website (eu1.make.com).