Delayed emails notification
Incident Report for Make
Resolved
This incident has been resolved. Email notifications are now processed without any delay.
Posted May 22, 2024 - 20:55 CEST
Update
We have implemented the fix and are currently significantly reducing the number of delayed emails. We expect the whole queue to be drained within the next 1 or 2 hours, after which we will provide an update.
Posted May 22, 2024 - 19:53 CEST
Identified
We have identified the issue and are working on implementing the fix. We will provide a new update within the next 2 hours.
Posted May 22, 2024 - 17:41 CEST
Investigating
We are currently investigating an issue where emails notifications can be delivered with a delay.

We will post updates within the next hour.
Posted May 22, 2024 - 16:35 CEST
This incident affected: Website (us1.make.com).