make.com page not accessible

Incident Report for Make

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 20:04 CEST

Monitoring

make.com public page was not accessible from 15:03 - 15:18 CET, users might encountered problems using the platform, login page and community pages stayed functional. The root cause was found and fixed. We are currently monitoring the issue.
Posted Jul 23, 2025 - 15:41 CEST
This incident affected: Website (make.com), Scenario Executions (make.com), and Apps (make.com).