Notion modules failing

Incident Report for Make

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 01:09 CEST

Monitoring

The fix has been implemented on all affected zones. We are closely monitoring performance to confirm full resolution.
Posted Oct 23, 2025 - 00:30 CEST

Identified

We identified the issue causing the error. We are working on the fix.
Posted Oct 22, 2025 - 23:15 CEST

Investigating

Multiple Notion modules are throwing HTTP 400 "Invalid request URL" error. We are investigating the issue.
Posted Oct 22, 2025 - 22:48 CEST
This incident affected: Apps (eu1.make.com, eu2.make.com, us1.make.com, us2.make.com, eu1.make.celonis.com, us1.make.celonis.com).